keep the same ip on both router and extender

Post Reply
User avatar
meteoesine
Forecaster
Forecaster
Posts: 129
Joined: Sun Aug 20, 2017 4:08 pm
Location: Esine, Valcamonica (BS) - Italy
Station model: Davis Pro2 + BloomSky cam
Software: Meteobridge
Contact:

keep the same ip on both router and extender

Post by meteoesine » Sat May 14, 2022 9:00 am

Hi, I turn to network configuration experts:
I have the purpleair device with static ip to the router 192.168.1.120 that I would like to keep such to be able to download data from meteobrdige.
It is positioned on the roof, the router signal reaches the limit of the threshold, sometimes falls, and reconnects to an extender positioned in the attic.
The problem is that when connecting to the extender the IP of the purpleair device changes and consequently the meteobridge no longer sees it. how do i keep the same ip for purpleair (192.168.1.120) on both router and extender?

I use a TPlink RE200 (configured only for 2,4Ghz), assuming it is feasible, who can give me some advice on how to configure it? or if there is some other extender able to do it?
many thanks in advance for any comments
Attachments
ScreenShot01033.jpg
ScreenShot01033.jpg (89.86 KiB) Viewed 1180 times
ScreenShot01032.jpg
ScreenShot01032.jpg (42.7 KiB) Viewed 1180 times
:arrow: https://meteoesine.it
ham wx aprs/cwop: IW2LAO-13

Image

FSC830
Newbie
Newbie
Posts: 3
Joined: Thu Aug 02, 2018 11:40 am
Station model: Davis Vantage Pro2
Software: Meteobridge

Re: keep the same ip on both router and extender

Post by FSC830 » Tue Jul 19, 2022 2:33 pm

Still no answer until today?

How many DHCP servers are in use in your LAN? Does the router and the extender run a DHCP service?
Usually only one DHCP should be used. In most routers there is an option like "use always same IP for this device" which you an enable for certain devices.
Next question: why not using a static IP instead of DHCP for that device?

Regards

Edit: no, you do not use a static IP! 192.168.1.120 is clearly within your DHCP range!
Do you really need a DHCP range from .2 to .254? This covers the whole subnet!
I recommend to limit the range (i.e. .20 to .100 or .200), so you have enough addresses left outside the DHCP range you can use for static IP.

Even worse: your TP link device uses a static IP of 192.168.1.147, this is within the DHCP range of the router! This should be avoided! Never setup a static IP with the range of a DHCP pool!
As a recommendation change DHCP pool at router to 192.168.1.20 to 192.168.1.100, router (my geuss) is 192.168.1.1, extender should use 192.168.1.2 (or any other IP up to .19).

User avatar
meteoesine
Forecaster
Forecaster
Posts: 129
Joined: Sun Aug 20, 2017 4:08 pm
Location: Esine, Valcamonica (BS) - Italy
Station model: Davis Pro2 + BloomSky cam
Software: Meteobridge
Contact:

Re: keep the same ip on both router and extender

Post by meteoesine » Thu Jul 21, 2022 12:39 pm

Thank you
:arrow: https://meteoesine.it
ham wx aprs/cwop: IW2LAO-13

Image

Post Reply