Station offline/online

Post Reply
User avatar
Ramonmartinez
Observer
Observer
Posts: 19
Joined: Mon Aug 21, 2017 7:06 pm
Location: Villaescusa de Haro
Station model: Froggit WH3000
Software: WU

Station offline/online

Post by Ramonmartinez » Sun Sep 18, 2022 11:17 am

Buenos días.
Desde la semana pasada, me llegan cada 10 minutos correos electrónicos informándome que mi estación esta offline, y a los 10 minutos online.
Los cronjob veo que se ejecutan correctamente, ya no se si es problema de Wunderground, de mi estación o de mi alojamiento web... :cry:

http://meteovillaescusadeharo.com/templ ... esktop.php
Image

User avatar
lemimi
Advisor
Advisor
Posts: 50
Joined: Wed Dec 12, 2018 3:31 pm
Location: France - Normandie
Station model: Brandson 304557
Contact:

Re: Station offline/online

Post by lemimi » Tue Sep 20, 2022 4:03 pm

Buenos dias,

Lo mismo para mí.
Fuera de línea y en línea de vez en cuando desde el comienzo de la semana pasada.
Completamente fuera de línea hoy. Wunderground que está haciendo lo suyo???

Mirando hacia adelante... Michel

***********************************
Bonjour,
Idem pour moi.
Offline et online de temps en temps depuis le début de la semaine dernière.
Aujourd'hui offline complet. Wunderground qui refait des siennes ???
Au plaisir...Michel

davidefa
Expert
Expert
Posts: 674
Joined: Tue Jan 12, 2021 8:03 am
Location: Italy
Station model: WH2650
Software: WH2650 (direct upload)
Contact:

Re: Station offline/online

Post by davidefa » Tue Sep 20, 2022 8:38 pm

Wu is not 'super reliable' ( see this post on wxforum: https://www.wxforum.net/index.php?topic=44397.0 )
For several minutes your site was 'alive' but the time difference between your server an wu varied wildly ( 1275 seconds in the extract below ).
If you have a wh3000 you might consider using the ecowitt plugin ( last version v3.0, which uses the custom upload function of your console, and does not rely on wu )

Code: Select all

add live data: ATime: 1663704307
calculated D: 20.6
calculated A: 26.1
Save meteotemplateLive.txt: {"SW":"wu","U":1663703338,"T":23.300000000000001,"H":85,"P":1014.5599999999999,"W":6.0999999999999996,"G":9.3000000000000007,"R":0,"RR":0,"B":204,"S":0,"SWTime":1663704613,"UTime":1663704613,"TTime":1663704613,"HTime":1663704613,"PTime":1663704613,"WTime":1663704613,"GTime":1663704613,"RTime":1663704613,"RRTime":1663704613,"BTime":1663704613,"STime":1663704613,"D":20.600000000000001,"DTime":1663704613,"A":26.100000000000001,"ATime":1663704613}
Start data parsing
Parsing date; Server time: 2022-09-20 22:10:13
Validating date: 1663703338 (2022-09-20 21:48:58)
Date is valid; difference with server time is -1275 s
Parsing temperature
Temperature: 23.3 C
Database units: C
Checking temperature is between limits specified in template Main settings.
Image

User avatar
lemimi
Advisor
Advisor
Posts: 50
Joined: Wed Dec 12, 2018 3:31 pm
Location: France - Normandie
Station model: Brandson 304557
Contact:

Re: Station offline/online

Post by lemimi » Fri Sep 23, 2022 9:22 am

Bonjour,

Ma station est une Brandson 304557
http://template.lemimi.fr/pages/other/aboutStation.php
J'ai essayé ecowitt 3.0 et ecowittNet 1.3 et cela ne veut pas fonctionner.
Je suis sous PHP 7.4, pas de redirection HTTPS comme conseilé dans les diverses conversations.
Voici comment j'ai configuré l'une et l'autre:

http://template.lemimi.fr/chargements/2 ... ittNet.pdf
http://www.template.lemimi.fr/chargemen ... imi.fr.png

Je dois certainement passer à côté de quelque chose ???
https://www.ecowitt.net/home/share?authorize=G228NQ

Grand merci de l'aide apportée et au plaisir... Michel
******************************************************
Hello,

My station is a Brandson 304557
http://template.lemimi.fr/pages/other/aboutStation.php
I tried ecowitt 3.0 and ecowittNet 1.3 and it doesn't want to work.
I am under PHP 7.4, no HTTPS redirection as advised in the various conversations.
Here's how I configured both:

http://template.lemimi.fr/chargements/2 ... ittNet.pdf
http://www.template.lemimi.fr/chargemen ... imi.fr.png

Surely I must be missing something???
https://www.ecowitt.net/home/share?authorize=G228NQ

Thank you very much for the help provided and to the pleasure... Michel

davidefa
Expert
Expert
Posts: 674
Joined: Tue Jan 12, 2021 8:03 am
Location: Italy
Station model: WH2650
Software: WH2650 (direct upload)
Contact:

Re: Station offline/online

Post by davidefa » Fri Sep 23, 2022 3:24 pm

@lemimi
I verified that there is some sort of problem with your setup ( for example no cache/apiLog.txt nor cache/apiCache.txt file is generated ).
I think I can debug the problem having access to your server ( I need the password of your server control panel, or at least an ftp access, not sure this is acceptable for you )
Image

andyk1
Professional
Professional
Posts: 415
Joined: Tue Feb 27, 2018 10:56 pm
Location: OKLAHOMA, USA
Station model: Ecowitt WS90
Software: Meteobridge/GW2000B
Contact:

Re: Station offline/online

Post by andyk1 » Sat Sep 24, 2022 5:02 pm

I've got a similar problem. It's when I tried the senor8 mod and accidentally copied over my latest backup and can't go back. It has to do with the modified api.php and updates in the update folder. It reverts back 3-4 min then catches up but knocks my CWOP out of wack. Look at the bottom of the page and look at cwop... and also WU doesn't accept my site as valid data.

Not sure where else to look.

Does anyone have an old copy of api.pho and the update folder before the ecowitt modes?

David, let me know if you have time to look at my site. I think I gave you my credentials in private awhile back but let me know if you don't have them.
Image

User avatar
lemimi
Advisor
Advisor
Posts: 50
Joined: Wed Dec 12, 2018 3:31 pm
Location: France - Normandie
Station model: Brandson 304557
Contact:

Re: Station offline/online

Post by lemimi » Fri Sep 30, 2022 4:16 pm

Hello,

It has been working perfectly under Ecowitt.net for 3 days.
No errors detected!
On the other hand the CRON task with the PHP command line interpreter, did not work:
with ecowiit (forced to go through the CRON task)
/usr/local/bin/php /home/domain.com/plugins/ecowitt/report/
also I have worked around using the CURL command, which gives:
curl domain.com/plugins/ecowitt/report/
This works but adds 2 hours to local time.

Same problem with Ecowitt.net:
/usr/local/bin/php /home/domain.com/load/cron.php?password=********
which doesn't work for me, so workaround:
curl domain.com/load/cron.php?password=**********


If it can help anyone...

To the pleasure... Michel
and thank you to Davidefa for his availability and his help to put me on a track.

Post Reply