Page 1 of 1

meteobridge and meteotemplate

Posted: Fri Aug 16, 2019 6:37 pm
by meteomw
Is there a manual to setup the meteobridge? I no longer get this set in the meteobridge for meteotemplate.

Re: meteobridge and meteotemplate

Posted: Sun Aug 18, 2019 1:52 pm
by iatros
Hi meteomw

login to: admin.meteobridge.com/xxxxxxxxx

Tab: Weather Network

at the bottom: add more weather networks, select meteotemplate

fill in interval, API URL (http://www.[your meteotemplate root folder]/api.php) and password

Done

Cheers, Martin

Re: meteobridge and meteotemplate

Posted: Sun Aug 18, 2019 1:57 pm
by meteomw
Thx Martin,
That is what I did but it do not work. I got the following message:
Error: Meteotemplate: https://www.meteomw.nl/template/api.php ... 9&PASS=<my password>: HTTPS support not compiled in.

Re: meteobridge and meteotemplate

Posted: Mon Aug 19, 2019 11:08 am
by meteomw
I got also the error messages:
1) Error: Meteotemplate: OpenSSL: error:14077410:lib(20):func(119):reason(1040)
2)error:14077410:lib(20):func(119):reason(1040) Unable to establish SSL connection. (5 more tries, next in 5 secs)

On advice of Smarbedded (supplier meteobridge) changed http to https.

Re: meteobridge and meteotemplate

Posted: Tue Aug 20, 2019 1:58 pm
by iatros
so you DID try http:// (instead of https://) ?

Hopefully Jachym happens to see this thread, he should be able to help you!

Re: meteobridge and meteotemplate

Posted: Tue Aug 20, 2019 2:02 pm
by meteomw
Thx for Your answer but both do not work

Re: meteobridge and meteotemplate

Posted: Tue Aug 20, 2019 8:43 pm
by Johnny
Hi Meteomw, for what it's worth the image below is how mine is set up, sounds like and http or https issue, maybe someone else on the forum can point you in the right direction.

Meteobridge-Weather-Nets.jpg
Meteobridge-Weather-Nets.jpg (80 KiB) Viewed 3321 times

Re: meteobridge and meteotemplate

Posted: Wed Aug 21, 2019 5:22 am
by meteomw
Thx Johnny, I have the same set-up only with my credentials and I also tried http and https. Nöt ing helps. Could it be a server problem?

Re: meteobridge and meteotemplate

Posted: Wed Aug 21, 2019 5:58 am
by meteomw
I have added two screenshots, perhaps that gives more clarity about the problem. I have also been in contact with Smartbedded and they indicate that it is probably a problem at / home / openssl / wget-ssl, but the webhoster indicates that this directory does not exist. Does anyone know what's going on?

Re: meteobridge and meteotemplate

Posted: Sat Aug 24, 2019 10:58 pm
by meteoesine
Hi,
since last night I have the site offline for the same reason.
Please someone give us an answer to solve the problem, having accurate that it is not a hosting problem
thanks in advance

Re: meteobridge and meteotemplate

Posted: Sun Aug 25, 2019 1:55 pm
by Asobig
Boris has released an update with the following description:
"updates openssl and wget support on MR3020 and Meteobridge PRO platform to handle HTTPS targets that do no longer support SSL (but only TLS) due to security concerns. Previous error message "OpenSSL: Error ... reason(1040)" should be resolved by this."

Perhaps a reboot of your Meteobridge will help.

Re: meteobridge and meteotemplate

Posted: Sun Aug 25, 2019 2:29 pm
by meteomw
thanks for the tip! I had to reboot and the problem is solved! It was strange yesterday that I had contact with Smartbedded and they indicated that it was not their fault but the web host. Anyway the problem has been solved. thx.