End of Service for the Weather Underground API

Post Reply
User avatar
Johnny
Developer
Developer
Posts: 306
Joined: Sat Aug 19, 2017 10:16 pm
Location: Watford, Hertfordshire, England
Station model: Davis Vantage Pro2 Plus
Software: Meteobridge
Contact:

End of Service for the Weather Underground API

Post by Johnny » Sat Oct 06, 2018 6:39 pm

Image
Davis Vantage Pro2 Plus: http://www.watfordweather.uk Bloomsky 2 & Storm: http://www.watfordweather.co.uk

User avatar
Fraggboy
Forecaster
Forecaster
Posts: 193
Joined: Wed Sep 27, 2017 2:45 pm
Location: Sunny California
Station model: Bloomsky II + Storm
Software: Bloomsky
Contact:

Re: End of Service for the Weather Underground API

Post by Fraggboy » Fri Oct 12, 2018 3:01 pm

Interesting read.

This really has me interested.. "If you are a Personal Weather Station owner, you will receive more information about our plan to offer free access to the data you provide to Weather Underground. We’ll reach out once that plan has been finalized."
Image

User avatar
Johnny
Developer
Developer
Posts: 306
Joined: Sat Aug 19, 2017 10:16 pm
Location: Watford, Hertfordshire, England
Station model: Davis Vantage Pro2 Plus
Software: Meteobridge
Contact:

Re: End of Service for the Weather Underground API

Post by Johnny » Fri Oct 12, 2018 3:38 pm

Let's wait and see what happens :)
Image
Davis Vantage Pro2 Plus: http://www.watfordweather.uk Bloomsky 2 & Storm: http://www.watfordweather.co.uk

User avatar
Fraggboy
Forecaster
Forecaster
Posts: 193
Joined: Wed Sep 27, 2017 2:45 pm
Location: Sunny California
Station model: Bloomsky II + Storm
Software: Bloomsky
Contact:

Re: End of Service for the Weather Underground API

Post by Fraggboy » Fri Oct 12, 2018 3:58 pm

I actually re-signed up to WU, so yes. I agree. We will see..
Image

nicoloconte
Newbie
Newbie
Posts: 7
Joined: Sun Jan 07, 2018 6:14 pm
Station model: WS1001
Software: WU

Re: End of Service for the Weather Underground API

Post by nicoloconte » Fri Jan 04, 2019 5:59 pm

"All Weather Underground API keys will stop working on February 15, 2019 unless otherwise agreed upon with Weather Underground."

https://apicommunity.wunderground.com/w ... api-update

nicoloconte
Newbie
Newbie
Posts: 7
Joined: Sun Jan 07, 2018 6:14 pm
Station model: WS1001
Software: WU

Re: End of Service for the Weather Underground API

Post by nicoloconte » Thu Jan 10, 2019 9:32 am

Just an info, actual weather station that send data to WU, will continue to work? Or I have to change weather station?

nicoloconte
Newbie
Newbie
Posts: 7
Joined: Sun Jan 07, 2018 6:14 pm
Station model: WS1001
Software: WU

Re: End of Service for the Weather Underground API

Post by nicoloconte » Sat Jan 26, 2019 5:17 pm


tinso
Newbie
Newbie
Posts: 3
Joined: Thu Sep 28, 2017 6:57 pm
Location: Alabama, USA
Station model: Acurite 5in1
Software: WU with custom api
Contact:

Re: End of Service for the Weather Underground API

Post by tinso » Sat May 25, 2019 10:05 pm

After my website been mostly down since the old WU API is been taking away (I own an AcuRite 5 in 1 which it only communicates with WU). I check on WU and I did got a new API key and thanks to user nicoloconte I was able to create an small php file to use that new API with the Meteotemplate API. Currently is working, I just finished a few hours ago so don't know the reliability of the new WU API. I uploaded this new php to the update folder and modified the cronjob to execute this one instead of the update.php. See attachment, don't judge this is my first php. Also make sure this php has execution permissions.
Attachments
NewWUAPI.zip
(604 Bytes) Downloaded 100 times

kevin
Observer
Observer
Posts: 11
Joined: Mon Feb 11, 2019 3:18 pm
Station model: froggit hp 1000
Software: graphweather

Re: End of Service for the Weather Underground API

Post by kevin » Sun May 26, 2019 2:15 pm

Hi Tinso just modify in my template have Froggit Hp 1000 SE and have same problem only work WU :( just make new file PHP and it s work now :) so have others parameter if you help me have Solar radiations and UV what add in the Php file ?

Find and have solution , share to other users :)

added in the php file :
$voSolarRadiation = ($obj['observations'][0]['solarRadiation']);
$voUv = ($obj['observations'][0]['uv']);

$mtURL = "http://your site.com/api.php?U=".$voTimeStm."&T=".$voTemp."&H=".$voHum."&P=".$voPress."&W=".$voWindSpeed."&G=".$voWindGust."&B=".$voWinDir."&R=".$voRainTotal."&RR=".$voRainRate."&S=".$voSolarRadiation."&UV=".$voUv."&PASS=yourpassword";

Uv not working older api , and now is ok :) solar radiation and uv now see on current conditions.
Very Thx for Job Tinso and nicoloconte.
Thx you

RobF
Observer
Observer
Posts: 42
Joined: Mon Nov 06, 2017 12:50 pm
Location: Clearwater Beach, Florida
Station model: Davis Pro 2 Plus
Software: WeatherLink.com
Contact:

Re: End of Service for the Weather Underground API

Post by RobF » Tue May 28, 2019 12:04 am

OK, beautiful I get the json data when using the https://api.weather.com/v2/pws/observat ... stationId=... URL, but the cron does not update the data and if I go into the Meteotemplate admin and try to set it up as a custom api with the new api script, and try the "Show Field Numbers" this is what I get:

Loading file...
Loading CSV/text file from NewWUAPI.php
File loaded successfully.
Starting to parse data....
Loaded data:
Field Number Value
0

So it appears I am missing a step.

Troubleshooting now, but any tips? Most likely I am missing something important...

tinso
Newbie
Newbie
Posts: 3
Joined: Thu Sep 28, 2017 6:57 pm
Location: Alabama, USA
Station model: Acurite 5in1
Software: WU with custom api
Contact:

Re: End of Service for the Weather Underground API

Post by tinso » Fri May 31, 2019 1:07 am

Kevin, I'm glad you got it working again, you're welcome. It's been very reliable so far only once I got a notification that the new WU API failed, but it was around 3am so I'm not complaining.
kevin wrote: Sun May 26, 2019 2:15 pm Hi Tinso just modify in my template have Froggit Hp 1000 SE and have same problem only work WU :( just make new file PHP and it s work now :) so have others parameter if you help me have Solar radiations and UV what add in the Php file ?

Find and have solution , share to other users :)

added in the php file :
$voSolarRadiation = ($obj['observations'][0]['solarRadiation']);
$voUv = ($obj['observations'][0]['uv']);

$mtURL = "http://your site.com/api.php?U=".$voTimeStm."&T=".$voTemp."&H=".$voHum."&P=".$voPress."&W=".$voWindSpeed."&G=".$voWindGust."&B=".$voWinDir."&R=".$voRainTotal."&RR=".$voRainRate."&S=".$voSolarRadiation."&UV=".$voUv."&PASS=yourpassword";

Uv not working older api , and now is ok :) solar radiation and uv now see on current conditions.
Very Thx for Job Tinso and nicoloconte.
Thx you

tinso
Newbie
Newbie
Posts: 3
Joined: Thu Sep 28, 2017 6:57 pm
Location: Alabama, USA
Station model: Acurite 5in1
Software: WU with custom api
Contact:

Re: End of Service for the Weather Underground API

Post by tinso » Fri May 31, 2019 1:15 am

RobF I think you're trying to use Custom File instead of the API option from the drop down. I don't export the json data to a csv, I extract the data that my WS provides and using the Meteotemplate API use it to update the webpage every 5 minutes. See here for information on how to use the API.

RobF wrote: Tue May 28, 2019 12:04 am OK, beautiful I get the json data when using the https://api.weather.com/v2/pws/observat ... stationId=... URL, but the cron does not update the data and if I go into the Meteotemplate admin and try to set it up as a custom api with the new api script, and try the "Show Field Numbers" this is what I get:

Loading file...
Loading CSV/text file from NewWUAPI.php
File loaded successfully.
Starting to parse data....
Loaded data:
Field Number Value
0

So it appears I am missing a step.

Troubleshooting now, but any tips? Most likely I am missing something important...

MacV
Newbie
Newbie
Posts: 3
Joined: Sun Sep 17, 2017 12:38 am
Location: Paremoremo, Auckland
Station model: Aercus Weathersleuth
Software: WU with custom API
Contact:

Re: End of Service for the Weather Underground API

Post by MacV » Sat Jun 01, 2019 12:20 am

Thanks Tinso and Kevin for sharing this solution, was getting tired of seeing station offline!

Regards
Marc
www.pare361.co.nz
Image

Post Reply